Import Member Ministry Information

In order to use this process, you must first import your member data.

After you import member data, you can import member ministry data. When you imported your member information, you assigned a value to the Member Key field. This value represents the field in your previous program that differentiated between member records. For example, if your previous program had a field called "Member Number" that assigned a unique number to each member record, this is the value you selected as the Member Key.

Each member ministry record must contain the same Member Key value. This links the member ministry information with the appropriate member record that you've already imported to your PDS Office program. Each record must also have a unique Member Key value that represents the field in your previous program that identified each member record. For example, if your previous program had a field called "Member ID" that assigned a unique number to each member record, this is the value you should select as the member key.

How this process works: Once you identify the .csv file, you will match the values in that file with your PDS Office program fields. There are a few required fields, but other than that, you only have to enter information for the data you want to import into your program. No data is imported until you click Begin Import on the final tab. Your selections are automatically saved on each tab, so you can come back to this process at another time if needed.

You can use the Import Member Ministry Information process to import existing member ministry data from a .csv file into your PDS Office program.

  1. On the File menu, click Import Data > Import Member Ministry Information.
  2. The backup dialog box displays if you haven't performed a daily backup.
    CAUTION: This process alters data. We recommend backing up your data before proceeding.
  3. The Import Ministry Information dialog box displays. On the File Information tab, click Browse to locate the .csv file. After you select a file and click Open, your data displays.
    Note: We strongly recommend that you include field names/headers so it's easier to select the corresponding value from the drop-down lists on other tabs.
  4. On the Keys/Ministry Data tab, select the appropriate values from the drop-down lists. For more information about fields on these tabs, refer to the related topic "Ministry Import Field Information".
  5. On the final tab, before you import your data, click Pre-Import Data Check. This creates a file called "PreImportMinistryReport.txt" in the program's data folder.
  6. Scroll through the items you're going to import to see if you need to make any adjustments.
  7. When you're ready to import the data into your PDS Office program, click Begin Import.
  8. Once the import is complete, a summary displays. This creates a file named "MinistryImportReport.txt" in the program's data folder.
  9. When you're done, click Finish.